Jquery1.11版本中$.browser不能用的问题解决方法

分类:jquery实践

 本文为大家介绍下jquery1.11下如何检测浏览器类型和检查是否为 IE6版本,下面有个不错的示例,大家可以参考下

Jquery1.11版本中$.browser已被剔除: 
 
判断浏览器类型: 
代码如下:
 
$.browser.mozilla = /firefox/.test(navigator.userAgent.toLowerCase()); 
$.browser.webkit = /webkit/.test(navigator.userAgent.toLowerCase()); 
$.browser.opera = /opera/.test(navigator.userAgent.toLowerCase()); 
$.browser.msie = /msie/.test(navigator.userAgent.toLowerCase()); 
 
等号后面的表达式返回的就是 true/false, 可以直接用来替换原来的 $.browser.msie 等。 
 
检查是否为 IE6: 
代码如下:
 
// Old 
if ($.browser.msie && 7 > $.browser.version) {} 
// New 
if ('undefined' == typeof(document.body.style.maxHeight)) {} 
 
检查是否为 IE 6-8: 
代码如下:
 
if (!$.support.leadingWhitespace) {} 
本文链接: Jquery1.11版本中$.browser不能用的问题解决方法
版权所有:后巴士在网络收集,如有侵犯你的权利, 请联系QQ:641868752。

评论

发表评论

*

* (显示gravatar头像)

Ctrl+Enter快捷回复

© 2014 后巴士 all rights reserved.